Submit your papersSubmit Now
For Enquiries: [email protected]
IIARD LogoIIARD

A Flexible Role Based Secure Messaging System: An Information System Perspective

Ositanwosu Obiajulu E., Ajonuma Michael E.

Abstract

In this research, we presented the construction of a flexible role-based secure managing service system which can operate in an open environment. The tool is aimed at providing protection of messages across domains, and caters to most of the commercial requirements for information integrity. The challenge of an unsecure messaging system was addressed by the construction of a flexible secure messaging service system, where role-based messaging and access control and messaging/permissions are managed based on roles, while authorization and encryption keys are sent to registered phone numbers. The Software Development Life Cycle was adopted to carry out a detailed study of the existing mailing service systems and role-based messaging systems with a view to identifying the problems and loopholes in the secure role-based mailing system. Analysis and design of the new system were performed using popular software design tools. This study also contributes to providing security features based on architecture design, and demonstrates the implementation of information confidentiality and privacy. Keyword: Messaging system, Information system, Software Development Life Cycle

References

[1] Alhogail, A. and Alsabih, A. (2021). Applying machine learning and natural language processing to detect phishing email. Computers & Security, 110. https://doi.org/10.1016/j.cose.2021.102414. [2] Allman E., Callas J., Delany M., Libbey M., Fenton J., and Thomas M. Domain Keys Identified Mail Signatures. RFC 4871 (Proposed Standard), May 2007. URL http://www.ietf.org/rfc/rfc4871.txt. [3] American national Standards Institute, Inc. Role-Based Access Control. ANSI INCIT 359-2004., retrieved May 10, 2021. [4] Chadwick, D. (2003). The X.509 Privilege Management Infrastructure. In Borka Jerman- Blazic, Wolfgang Schneider, and Tomaz Klobucar, editors, proceedings of the NATO Advanced Networking Workshop on Advanced Security Technologies in Networking, Bled, Slovenia, September, 2003. [5] Chadwick, D., Zhao, G., Otenko, S., Laborde R., and Su, L. (2006), Building a modular authorization infrastructure. In UK e-Science All Hands Meeting 2006, September, 2006. [6] Chadwick, D., Lunt, G., and Zhao G. (2004). Secure Role based Messaging. In Eighth IFIP TC-6 tc-11 Conference on Communications and Multimedia Security (CMS 2004), Windermere, UK, September, 2004. [7] CCITT (1988) Recommendations X.400, Message Handling System and Services Overview. Retrieved May 12, 1013. [8] Crispin, M. (2003). RFC 3501-Internet Message Access Protocol-Version 4revl. Request for Comment, Network Working Group. [9] Crocker, D. H. (1982). RFC 822-Standard for ARPA Internet Text Message Request for Comment, Network Working Group. [10] Ekins, M. (1996). RFC 2015-MIME Security with pretty Good Privacy Request for Comment, Network Working Group. [11] Elkins, M., Del-Torto, D., Leveien, R., and Roessler, T. (2001). RFC 3156 _MIME Security with Open PGP Request for Comment, Network Working Group. [12] Freed, N. and Borenstein, N. (1996). RFC 2045- Multipurpose Internet Mail Extension Part One: Format of Internet Message Bodies. Request for Comment, Network Working Group. Retrieved August 18, 2021. [13] Gamma, E., Helm, R., Johnson, R., & Vlissides, J. (1994). Design Patterns: Elements of Reusable Object-Oriented Software. Addison-Wesly. [14] Gellens, R. and Klensin, J. (1998), RFC 2476-Message Submission. Request for Comment, Network Working Group. [15] Hasselbach, J. (2003). A Practice-Oriented Approach to Security Enhanced Mailing Lists. In The Sixth International Conference on Electronic Commerce Research, Dallas, US. [16] Hoffman, P. (1999). RFC 2634-Enhanced Security Services for S/MIME. Request for Comment, Network Working Group. [17] Klensin, J. (2001). RFC 2821-Simple Mail Transfer Protocol. Request for Comment, Network Working Group. [18] Klensin, J., Freed, N., Rose M., Stefferud, E., and Crocker, D. (1995). RFC 1869-SMTP Service Extension. Requsr for Comment, Network Working Group. Retrieved August 18, 2021. [19] Levine, J. R. (2004). The Trusted Email Open Standard . Internet Engineering Task Force. 1 – 8. https://datatracker.ietf.org/doc/html/draft-levine-epg-teos-00. IJCSMT [20 ]Lyon, J., and Wong, M. (2004). Internet Draft: Sender ID: Authenticating E-Mail. Internet Draft, Retrieved May 12, 2021. [21] Lyon, (2005). Purported Responsible Address in E-Mail Messages. Microsoft Corp. https://tools.ietf.org/pdf/draft-lyon-senderid-pra-00.pdf [22] Manji, K., Hanefeld, J., Vearey, J., Walls, H. and De Gruchy, T. (2021). Using WhatsApp messenger for health systems research: a scoping review of available literature. Health Policy and Planning, 36, 2021, 774–789 [23] Matthew Martin. 2021. SDLC: Phases & Models of Software Development Life Cycle. Guru99. https://www.guru99.com/software-development-life-cycle-tutorial.html#11 [24] Mont, M. C., Bramhall, P., and Harrison, K. (2003). A Flexible Role-based Secure Messaging Service: Exploiting IBE Technology for Privacy in Health Care. In Proceeding of the 14th International Workshop on Database and Expert System Applications. IEEE [25 ]Myers, J. (1996). RFC 1939-Post Office Protocol-Version 3. Request for Comment, Network Working Group. Retrieved August 18, 2021. [26] Oppliger, R., Gunther, P., and Christine S. (2000). Using attribute certificates to implement role based authorization and access controls. In S. Teufel K. Bauknecht, editor, Scherheit in Information System (SIS 2000), pp 169-184, Zurich. [27] Osborn, S. L. (2002). Information flow analysis of an rbac system. In Sacmat ’02: Proceedings of the seventh ACM symposium on Access control models and technologies, 2002. [28] Postel, J. B. (1982). RFC 821-Simple Mail Transfer Protocol. Request for Comment, Network Working Group. [29] Ramsdell, B. (1999). RFC 2633-S’MIME Version 3 Message Specification. Request for Comment, Network Working Group. [30] Wolthusen S. D. (2003). A Distributed Multipurpose Mail Guard. In The 2003 IEEE Workshop on Information Assurance, West Point, NY, US. [31] Wong M. and Schlitt W. Sender Policy Framework for Authorizing Use of Domains in E-Mail, Version 1. RFC 4408 (Experimental), April 2006. URL http://www.ietf.org/rfc/rfc4408.txt